Account History - Problem with Calendar and HipStamp Staff

I'm unable to select a date range for this function. The popup calendar is cut off and only allows me to go back to 10/10/21. This has worked in the past, but now that I need it to complete my taxes, it won't work. I sent a message to HipStamp, but they only told me how it should work and then provided me a copy of the sales summary for 2020 which I already had. I had asked for a total of fees paid to HipStamp, so I don't know why they would send me the sales summary. I again asked for the total fees paid to HipStamp. They simply sent me the boilerplate again of how it should work and also advised I needed to contact PayPal (which the wouldn't have fees paid to Hipstamp because they take their payment from my credit card) and they also recommended that I contact an accountant to assure accuracy on tax reporting. Again I asked for fees paid to HipStamp and just got back an automated reply that they received my email and would get back to me later.

I now understand how frustrating it can be when problems occur here and aren't corrected properly in a timely manner. Now that I have expressed my frustrations, are others having problem with this feature concerning fees paid to HipStamp?

I guess I'm going to spend my night thumbing thru pages of individual fees to find the payments actually paid to HipStamp. I received a 1099 from PayPal. Isn't HipStamp required to also provide one? If they did, I didn't get mine.


  • 15 Comments sorted by Votes Date Added
  • John,

    If you kept your credit card statements they are itemized on your credit card statement. They should be listed under transaction by the transaction date, post date and description.
  • John:
    This works for me:
    Go to members area
    Account history
    Select date range you are interested in
    Filter by Receipts
    You will end up with a list of the monthly charges from HipStamp
    or Filter by Debit and you will get a list of fees charged to you by transaction
  • Strange that it works for you. I have tried it on two different computers and I get the same result. I can't select a date range. When I try to put in either the beginning or ending date, the top part of the pop-up calendar is hidden under the banner that shows Home, Browse, etc. with only the days from 17 forward visible.

    I can't located my credit card statements, so I'm manually going thru the individual pages in account history. I have 5 months done. Only 7 more to go.
  • You may want to place them in a file folder so you have them all in one place. (And it helps when they are in the same place you have the rest of your paper work.) They are a good back up to have.
  • John
    It appears that you need to hit the done button at the bottom of the date entry screen for the date to be accepted. Double clicking on the date does not seem to work
  • My calendar only shows dates starting with 17. When I place the cursor above it and hit done, I get 10/10/21. I'm almost done getting the info I need via the individual pages. When I have time, I will reboot my system to see if this problem is corrected.
  • John all of your credit card statements are on line.
  • edited October 2021 0 LikesVote Down
    you may have better luck if you change browsers? just a thought. Google can be very frustrating at times.. i moved to firefox. -not too sure on msn browsers
  • I use Chrome. After additional discussion with HipStamp, it was determined that my zoom setting was too high. When I reduce it to 67% (which is hard for me to read) it works, provided I don't try to reduce the zoom setting with the calendar open. They say no one else has had an issue with this, but this was my fix just in case this issue presents itself to some other unlucky sole.
  • Soul? Just kidding.....Browsers can be finicky at times for sure.
  • Can't get my mind off my sore feet.
  • HAHAHA! I get it!
  • Do they smell like fish?
  • Cat and dog feet. Like litter or epoxy curing.
  • I just saw the same problem in Microsoft Edge, but it is intermittent. When I tried a second time the problem went away.
Sign In or Register to comment.